Ubuntu16.04にBracketsをインストール

Ubuntu16.04LTSだと、依存パッケージの問題でAdobeのBracketsが入りません。

なんで?

GitHub上でも英語ですが議論されている問題で、Ubuntu16.04LTSでは「libgcrypt11」というパッケージがリポジトリに無いのが原因らしい(「libgcrypt20」はあります)です。
When attempting to install Brackets on Ubuntu 16.04 LTS, the installation fails silently (if not done via dpkg on the command line). This is because Brackets depends on libgcrypt11; the installation routine remarks that libgcrypt11 is not installed. Ubuntu 16.04 only comes with libgcrypt20.
The installation of the transitional libgcrypt11-dev does not resolve the problem (is only a dummy-package)
The attempted installation leaves the packaging system in a state of unresolved dependencies sudo apt-get -f install fixes the problem though.

(暫定)解決策

Adobe側で対応してくれるのが望ましいんですが絶望的な感じがするため、取り敢えずLaunchPadにlibgcrypt11が残っている(直リンク)ので、ダウンロードしてGdebiかUbuntuソフトウェアでインストールします。
また、PPAを使う方法もあるようです(試していない)。

その後、Bracketsのdebファイルをここからダウンロードし、改めてインストールします。
これでUbuntu16.04上でもBracketsが使えるようになりました。

2017/07/24追記:最新版では、Linuxのネイティブなメニューバーを使用するようになったようです。

訂正:braketsではなくbracketsでした。失礼しました。

コメント

このブログの人気の投稿

Ubuntuでファミコン、ゲームボーイ、スーファミの名作をプレイ!

メインブラウザをFirefoxからVivaldiに乗り換えました